
Password Corral

Welcome to Password Corral's on-line help. You can get to this help file from Password Corral at any time by pressing 'F1'. You can also get specific help on most items by right-clicking on them and selecting "What's This?" Choose 
from the following options:

{button ,AL(`Jump to whats new',1)} What's new in this version
Display the latest features and options added to Password Corral.

{button ,AL(`Jump to Password Corral features',1)} Password Corral features
Get a run down on the features in Password Corral.

{button ,AL(`Jump to program operation',1)} Program operation
Detailed information on how to use Password Corral.

{button ,AL(`Jump to legal information',1)} Legal information
Important legal information regarding copyrights and distribution of this program.

{button ,AL(`Jump to Cygnus Productions',1)} About Cygnus Productions
Information about our company.



What's new

Here's what's new in Password Corral v2.1:

Auto-Export
You can now set Password Corral to automatically export your password list when the program is exited. This can aid you in your backup routine and help you prevent password loss.

Other Goodies
A number of other internal enhancements and minor bug fixes are also included in this new version. Read the WHATSNEW.TXT file for complete information.

We hope you enjoy the new features we've added to Password Corral. We plan to make continuous updates to the program and add as many new things as we can. Your input is always valuable to us. Send any comments, problem 
reports or your wish list to us via e-mail. Click here for information about our company.

{button ,KL(`Password Corral')} Related Topics



Features

It's amazing what you can get for free! Below is a detailed list of the features included in this version of Password Corral:

Single Repository for all your Passwords
Now you can have a single place to store all your passwords. Use a single password that you choose to encrypt all the passwords you use. Never forget one again!

Password Information
Each password you store in Password Corral can also have a description, username and notes. No more forgetting which password went with which system. This information can be printed as well.

Diamond2 Encryption
Diamond2 128-bit key encryption stands between you and those unscrupulous persons with prying eyes. Unless they know your user name and Password Corral password, they can't see your data. All your passwords are stored 
in the Windows registry using the same 128-bit encryption. (Note: Password Corral is for distribution in the USA and Canada only. If you are a resident of another country you may not use Password Corral, download it in any 
electronic form or distribute it in any way.)

Password Expiration
Any password can be set to expire after a given number of days. Password Corral will then issue a warning when a password has expired. This will help to remind you to change you passwords for better security.

Multiple Users on the Same PC
Any user of your PC can create a new Password Corral account. The program keeps track of individual users and their data. Everyone's information is protected with their own password guarded by Diamond2 encryption.

Import/Export Passwords
Password Corral can export your password list to a text file easily! Copy the file to any other PC that has Password Corral, create a new user account for yourself and then import the passwords. Your passwords will now be 
available on the new PC. The text file also makes a handy backup in case of disaster. An auto-export feature allows you to create a backup password file each time you exit the Password Corral. And as you'd expect, the text file 
guards your passwords with Diamond2 encryption. 

Full On-line and What's This Help
Password Corral comes with complete, context sensitive on-line help. Just press 'F1' in any dialog box for specific information. Password Corral also supports What's This help. Right-click on most any object and select What's 
This from the pop-up menu for quick information on the object’s use.
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Program operation

Choose from the following list of features:

{button ,AL(`Jump to new user',1)} Creating a new user account
Information on creating a new user account.

{button ,AL(`Jump to log on',1)} Logging on to Password Corral
How to log on to Password Corral.

{button ,AL(`Jump to add password',1)} Adding new passwords
Adding new password information to Password Corral.

{button ,AL(`Jump to edit password',1)} Editing existing passwords
Editing existing password information in Password Corral.

{button ,AL(`Jump to remove password',1)} Removing a password
Removing passwords from Password Corral.

{button ,AL(`Jump to export passwords',1)} Exporting passwords
Exporting your current password list.

{button ,AL(`Jump to import passwords',1)} Importing passwords
Importing a new password list.

{button ,AL(`Jump to change password',1)} Changing your logon password
How to change your logon password.

{button ,AL(`Jump to program options',1)} Program options
How to set different options in Password Corral.
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Creating a new user account

If you’re using Password Corral for the first time on a new PC, you must create a user account for yourself. Follow the procedure below:

1 Click the 'New User' button from the logon screen. You will be presented with the New User dialog box.
2 Enter your username. This will be the name you type in when you want to log into Password Corral.
3 Enter a password.
4 Retype the password in the Verify text box to make sure you've entered it correctly.
5 Click 'Done' to complete the new user creation.

Once you've created the new user account you'll be returned to the main logon dialog box. Enter the username and password for the account you just created and click 'Done' to logon and start using Password Corral.

{button ,KL(`Password Corral')} Related Topics



Logging on to Password Corral

To logon to Password Corral:

1 Enter your username.
2 Enter your password.
3 Click the 'Done' button to logon.

If Password Corral doesn't recognize your username, it will ask if you'd like to create a new user account.
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Adding new passwords

To add a new password to the password list: 

1 Click the 'New Password' toolbar button or select 'New Password' from the Edit menu.
2 Enter a description. This can be the name of the network server the password belongs to, the server's location, or any other short description you wish.
3 Enter a username. This is the name you use to log into the given system. If there is no username, simply leave this field blank.
4 Enter the password. This is the actual password you want to keep track of using Password Corral.
5 Retype the password to verify you've entered it correctly.
6 If you wan Password Corral to warn you when the password is getting old, check the warning box and then enter then number of days that Password Corral issue warning in. You can also set the initial warning period as 

well by filling in the 'Current days till expiration' field.
7 Enter comments about the new entry. You can give a detailed description about the new password in the box.
8 Click the 'Done' button to store the password.

When complete, the new password will be stored and encrypted in the Windows registry. 
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Editing existing passwords

To edit an existing password in the password list:

1 Select 'Edit Password' from the Edit menu or double-click on the password you wish to edit.
2 Change the description name.
3 Change the username.
4 Change the password.
5 Retype the password to verify you've entered it correctly.
6 Enable or disable password warnings.
7 Change the comments about the entry.
8 Click the 'Done' button to store the edited information.

When complete, the edited information will be stored and encrypted in the Windows registry. 
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Removing a password

To remove a single password:

1 Select the password from the list that you wish to remove by clicking on it.
2 Click the 'Delete' toolbar button or select 'Delete' from the Edit menu.
3 If the 'Warn before deleting passwords' option is enabled, you will receive a warning before the password is deleted. Otherwise, the password will be removed immediately.

To remove all passwords in the list:

1 Click the 'Delete All' toolbar button or select 'Delete All' from the Edit menu.
2 You will be warned about the impending delete. Click 'OK' to remove all the passwords or 'Cancel' to terminate the action.

When complete, the password(s) will be removed from the Windows registry. 
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Exporting passwords

To export your current password list:

1 Click the 'Export Passwords' toolbar button or select 'Export Passwords' from the File menu. The Export Passwords common dialog box will appear.
2 Select the drive and folder you want the export file to be created in, and then type the name of the file you wish to save the passwords in.
3 Click the 'Done' button to create the export file.

When complete, a text file with the filename you chose will be created in the path/folder you selected. Exported passwords in the file are encrypted. (Note: the exported password list cannot be imported using previous versions of 
Password Corral)

{button ,KL(`Password Corral')} Related Topics



Importing passwords

To import a password list:

1 Click the 'Import Passwords' toolbar button or select 'Import Passwords' from the File menu. The Import Passwords common dialog box will appear.
2 Select the drive, folder and file the passwords are located in and click 'Open'. The Import dialog box will now appear.
3 Enter the password that was used to create the password list you're importing.
4 Select whether the import should overwrite your existing password list or append the new passwords to your existing ones.
5 Click the 'Done' button to import the password list.

When complete, you new passwords will be displayed in the main window.
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Changing your logon password

Your logon password is very important for two reasons. First, it gives you and only you access to your password information. Second, Password Corral uses your logon password as a key to encrypt the system password information 
your store in the program. You may wish to change your logon password from time to time in order to maintain good security habits. Follow the steps below to change your logon password:

1 Select 'Change Logon Password' from the File menu.
2 Enter your existing password in the 'Old Password' text box.
3 Enter a new password in the 'New Password' text box.
4 Retype the new password in the 'Verify Password' text box to verify you've entered it correctly.
5 Click the 'Done' button to change your logon password.

When complete, all existing passwords in your password list will be re-encrypted using your new password. The next time you log on to Password Corral you must use the new password.
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Setting program options

You can set or alter various options in Password Corral from the Options dialog box. Select 'Options' from the 'Tools' menu or click the toolbar button.

General Options Tab:
Check 'Warn before deleting passwords' to receive a warning before a password is deleted from the password list.
Check 'Clear contents of Windows Clipboard on exit' to clear any password information you may have copied to the clipboard when exiting Password Corral. Note that this will clear the clipboard of any information 

that's currently stored in it, whether placed there by Password Corral or not.

Export Options Tab:
Check 'Automatically export passwords on exit' to export your password list automatically when you exit Password Corral. Fill in the path and filename information in the field below where Password Corral should 

save the password information. Click the '...' button to browse for a directory.

Menu Options:
Check the 'Show Passwords' menu option or click the toolbar button to show the decrypted passwords on the screen.
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Legal Information

Password Corral is ©Copyright 1997-99, Cygnus Productions. All Rights Reserved. The Cygnus Productions 'Swan' and 'Space' logos are trademarks of Cygnus Productions. Cygnus Productions retains all rights over all aspects of the 
Password Corral program.

Password Corral is being released as Freeware. It may be used by individuals or companies at no cost as long as the software remains unmodified. Password Corral may be freely distributed by individual users (disk vendors or other 
shareware/freeware distributors, see below). Modification to the software, and any files included with it, without the written permission of Cygnus Productions is strictly prohibited.

Due to US export laws on cryptographic materials, Password Corral is for use in the United States and Canada only. People who reside in countries other than the US or Canada may not use or distribute Password Corral in any fashion.

Password Corral is NOT public domain software. It may not be resold for profit, or included in or with any other software without the written permission of Cygnus Productions. The program code may not be decompiled, reverse 
engineered or reused for any reason.

Because this program is being released for free, Cygnus Productions cannot be held liable for any problems or damage this program may cause to your computer. Use it at your own risk.



Founded in the year 2112, Cygnus Productions awoke to a city of software utility deprived people. Watching the people, humbled by the large institutions that insisted upon tremendous expense for basic needs, Cygnus Productions 
stepped forward to bring simple, easy to use utilities like this one to the common person. We hope Password Corral will prove to be as useful to you as it was fun to make.......(with a tip o' the hat to Neil Peart and the Boys)

This utility is free to all, but donations will be accepted. If you wish to send money, send what you think the program is worth to you to the address below. Make checks or money orders payable to David M. Fornalsky...U.S. greenbacks
are always welcome! (To date we've received US$0.00 dollars. How deep should we read into this? <BG>) Rush fanatics and National Midnight Star members need only think about us while playing 'Camera Eye' real loud. We'll hear 
you...

Cygnus Productions
Feel free to tell us what you think about this program and any suggestions you
might have. Or if you find a bug, please report it. Here's how to contact us:

E-mail: cygnus@mcs.com
WWW: http://www.mcs.com/~cygnus
Snail Mail: 7336-1 Winthrop Way

Downers Grove, IL 60516
USA



This is the Password Corral main toolbar. Hold the mouse pointer over the buttons to find out their use.



This is the password list. It displays all the password and system information you've stored in Password Corral.



This is the comments text box. It displays comments you've entered for the currently selected password entry.



This is the Description text box. Enter a short description for the password.



This is the Username text box. Enter the username that goes along with the password. If there is no username, simply leave this field blank.



This is the Password text box. The password you enter here will be encrypted in the Windows registry.



This is the Verify text box. Retype the password here to make sure you've entered it correctly.



Check this box to have Password Corral warn you when the password has expired after a given number of days.



Enter the interval at which Password Corral should warn about the password's expiration.



Enter the current number of days till the password expires.



This is the Comments text box. Enter a long description of the password and system. It may be left blank if desired.



This is the Old Password text box. Enter your current password.



This is the New Password text box. Enter the new logon password.



This is the Verify Password text box. Retype the new logon password to make sure you've entered it correctly.



Check this box to receive a warning before removing a password from the password list.



Check this box to clear the contents of the Windows Clipboard when you exit Password Corral.



This is the import Password text box. Enter the password that was used to encrypt the password list you're about to import.



Select this option if you want the imported passwords to be added to your existing password list.



Select this option if you want the imported passwords to overwrite your existing password list. Be careful, as you cannot recover passwords that have been overwritten.



Select this option if you want Password Corral to automatically export your password list when the program is exited.



Enter the path and filename where the automatically generated export file should be saved. Click the '...' button to browse for a specific folder.




